DNSクエリー送信ツール
説明
digコマンドや drillコマンドのように DNSクエリーを送信し、受信した内容を表示します。
■デフォルトではフルサービスリゾルバーの動作 (処理) を体験できるようになっています。
- 「対象ドメイン名」を入力して「送信」してください。
- AUTHORITYや ADDITIONALの情報に含まれるドメイン名 (NS) や IPアドレス (A, AAAA) をクリックすることで、委任を辿る (非再帰検索/反復検索を体験する) ことができます。
- 「クエリー先DNSサーバー」は別の権威サーバーのドメイン名か IPアドレスを入力することもできます。
- 「Qminiリセット」をクリックすることで、各種パラメーターを保持しつつ、以下のパラメーターをデフォルト値に戻します。
- 「クエリー先DNSサーバー」を「a.root-servers.net」にします。
- QNAME minimisationにおけるドメイン名の位置情報 (どのラベルより後ろを問い合わせているか) をリセットします。
■スタブリゾルバーの動作 (処理) も体験することができます。
- 「クエリー先DNSサーバー」にフルサービスリゾルバーのドメイン名か IPアドレスを入力し、
- 「対象ドメイン名」を入力して、
- 「RDフラグ」にチェックを入れて、
- 「送信」してください。
- 名前解決は入力したフルサービスリゾルバーが代わりにやってくれますので、これ以上の操作は不要です。
■拡張解析機能 (RFC対応)
- ヘッダー情報: Opcode / QR / Reserved (Z) フラグ等の解析・表示
- RFC 2308 (Negative Caching): NXDOMAIN / NODATA 応答時のネガティブキャッシュ有効期間 (TTL) の算出・表示
- EDNS0 オプション解析: EDNS Client Subnet (ECS, RFC 7871), DNS Cookie (RFC 7873/9018), Padding (RFC 7830), NSID (RFC 5001), EDE (RFC 8914), MQTYPE (RFC 10029) の自動デコード
- リソースレコード解読: TLSA (RFC 6698), SSHFP (RFC 4255), NAPTR (RFC 3403), HTTPS/SVCB (RFC 9460) 等のフォーマット解読
※DNSSEC検証はしません。